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Figure 1: The VirtualCZ User Interface




1 Introduction

VirtualCZ is an emulation of the synthesis engine from the CASIO CZ range of synthesisers
that were produced in the 1980s. It also functions as an editor for those synthesisers, since
it can save, load and transmit CZ System Exclusive (SYSEX) data. VirtualCZ offers many
enhancements and extra features to increase the possibilities and improve usability.

The CZ series are digital synths that use a technique known as Phase Distortion - a close
relative of Frequency Modulation (FM) made popular by Yamaha’s DX series. Unlike FM
synthesis, CASIO’s Phase Distortion method is very simple to control. Dramatic changes
in the audio spectrum can be created by manipulating one parameter. This has a similar
effect to changing the filter cutoff frequency in subtractive synthesis, although there is no
filter in Phase Distortion synthesis. The CZ synths were some of the first affordable poly-
phonic synthesisers, but were valued for their unique sound above anything else. They are
capable of producing interesting synth string, brass and pad sounds as well as great bells,
metallic percussion and synth bass. Many people fondly remember the CZ synths and they
have become retro-classics that are highly sought after. They were used on classic techno,
house, rave and synth-pop records in the late 80s and early 90s and lots of artists still use
them today for their unique sounds. Sadly many of the hardware units are in a bad state or
are malfunctioning in one way or another after 30 years of life.

With VirtualCZ we have tried to bring the classic CZ sound and feel into the modern Digital
Audio Workstation (DAW) workflow, and make a convienient editor for those musicians who
have the real thing. Whether you are a software fan or a hardware fan, we hope you enjoy
VirtualCZ!

Oli Larkin.

1.1 Key Features

e Recreates the unique Phase Distortion synthesis engine of CZ synthesisers

e Two CZ-Style PD oscillators per voice (each has eight wave shapes, which can be
different for alternate cycles)

e Six loopable envelopes per voice

e Switch envelopes between easy-to-use ADSR and more powerful eight-stage MSEG
modes

e Tempo syncable LFO for vibrato, with 7 shapes

e 32 voice polyphonic/mono/legato modes

Unison and detuning effects

Ring Modulation and Noise Modulation

Vintage stereo chorus/ensemble effect (two different algorithms)

Easy to use interface: all key synthesis functions accessible on the front panel

e Works as a SYSEX editor/librarian for hardware as well as an emulation (access thou-
sands of patches online)



Available in VST2, VST3, AU, AAX plug-in formats and Stand-alone app (.app/.exe)

Built-in preset browser

Import/export presets for all plug-in formats

Micro-tuning and MIDI scaling functionality

Polyphonic and Channel aftertouch support

1.2 System Requirements

VirtualCZ has been tested in the majority of compatible plug-in hosting digital audio software
for Windows and Mac OSX.
Mac

e OSX Mavericks (10.9) or higher

e 64bit VST 2.4, VST 3, AAX or Audio Unit host

e Pro Tools 11.02+ for AAX

e Minimum Intel i5 CPU and 4GB ram or more recommended

Windows
e Windows XP, Vista, 7 or 8
e 32bit or 64bit VST 2.4, VST 3 or AAX host
e Pro Tools 10.36+ or Pro Tools 11.02+ for AAX

e Minimum Intel i5 CPU and 4GB ram or more recommended

1.3 Installation

Mac

On the Mac platform VirtualCZ is distributed as a .dmg disk image named something like
VirtualCZ-v1.0.0-mac.dmg (depending on the version number). Double click the .dmg file
to mount the disk image. You should then see the contents of the disk image in the OSX
Finder. Double click the icon labelled VirtualCZ Installer.pkg to install the plug-in and click
"Continue" to go through the various stages of the install. You will be presented with the
"readme" and EULA which you will need to agree to. If you wish to perform a custom install
in order to save hard disk space (for example, by only installing one plug-in format), you
can click the "Customise" button on the "Installation Type" page. You are required to install
the "VST3 Presets" and the manual even if you don’t intend to use the VST3 version of the
plug-in, since these are also used by the other plug-in formats. You will be required to enter
an administrator password in order to install VirtualCZ.
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Standard Install on “Macintosh HD”

© Introduction
© Read Me This will take 40.6 MB of space on your computer.

© License Click Install to perform a standard installation of
© Destination Select this software on the disk “Macintosh HD”.
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@ Installation

@ Summary
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Figure 1.1: Mac Standard Installation
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Figure 1.2: Mac Custom Installation



Windows

On the Windows platform VirtualCZ is distributed as a .zip file named something like VirtualCZ-
v1.0.0-win.zip (depending on the version number). You should extract the contents of
the .zip file to somewhere convenient on your hard drive and then launch VirtualCZ In-
staller.exe by double clicking it in Windows Explorer. You can then proceed through the
installer stages by pressing the next button. You will need to accept the End User License
Agreement. On Windows, VST2 plug-ins can go in different locations and the installer will
ask you to confirm where you want to put those files. It will try and obtain the correct loca-
tion from the Windows registry, but pay attention because sometimes the registry value is
incorrect or missing and you could end up installing the plug-in to the wrong folder. In this
case it won’t show up in your VST2 host/DAW! The installer will give you the option to install
both the 32-bit and 64-bit plug-in versions on a 64-bit OS, and you should be careful not to
install the 64bit .dll file to the 32bit VST2 plug-ins folder and vice versa.

VirtualCZ installer -

Select Components
Which components should be installed?

Select the components you want to install; clear the components you do not want to
install. Click Next when you are ready to continue.

Full installation v

[v|Standalone app (.exe) ~
[+]32-bit VST2 Plugin (.dll)

[]64-bit VST2 Plugin (.dll)

[]32-bit VST3 Plugin (.vst3)

[]64-bit VST3 Plugin (.vst3)

[+]32-bit AAX Plugin (.aaxplugin) for ProTools 10

[]64-bit AAX Plugin (.aaxplugin) for ProTools 11

VSTZ Presets

+ VST3 Presets (Also used by other formats) v

Current selection requires at least 22.3 MB of disk space.

< Back Cancel

Figure 1.3: Windows Installation

1.3.1 Registering the Plug-in

If you previously installed the demo version of VirtualCZ you should download the full ver-
sion from your pluginboutique.com account and install it using the above instructions. Once
you've installed it, you will need to launch it and input the serial number in order to register
it. To get your serial number, visit your pluginboutique.com account and locate the product
section that lists your personal serial number for VirtualCZ. Your VirtualCZ Serial Number
will look like this:

START|Your Name|your@email.com|XXXX-XXXX-XXXX-XXXX|END

Click the copy button (see Figure 1.4) to copy the serial number to the clipboard or select
the whole serial number including the words START and END and copy to the clipboard
with CTRL-C/COMMAND-C. You can then launch the plug-in or stand-alone app and paste
the serial in, just by clicking the box that says "Thanks for purchasing VirtualCZ!...". The
box should change colour as you move your mouse over it to indicate that you can click it.
If it doesn’t, make sure the plug-in window has focus, by clicking the title bar.


http://www.pluginboutique.com/myaccount
http://www.pluginboutique.com/myaccount

®

Figure 1.4: Copy your serial number by clicking the clipboard icon in your pluginboutique.com account

1.3.2 Installing for Multiple Users

Normally when you paste your serial number into VirtualCZ it will authorize the plug-in for a
single user on the computer. This will be suitable for the vast majority of machines. If you
wish to register the plug-in for all user accounts on the computer (for example in a class-
room setting) you can either register it using each user account or you can manually move
the file key.txt to the following locations:

Mac

MOVE ~/Music/VirtualCZ/key.txt
TO /Library/Application Support/VirtualCZ/key.txt

Windows

MOVE %LocalAppData\VirtualCZ\key.txt
TO %ProgramDatal\VirtualCZ\key.txt
1.3.3 Uninstalling

Mac To uninstall VirtualCZ on OSX, you should manually remove the plug-ins from the
various plug-in folders. Delete your registration by removing

~/Music/VirtualCZ/key.txt

Windows On Windows you can run the VirtualCZ uninstaller. You can find a shortcut to it in
the Start Menu or by searching on the Start Screen (Windows 8). Delete your registration
by removing

%hLocalAppDatal,\VirtualCZ\key.txt


http://www.pluginboutique.com/myaccount

2 Getting Started - Using Presets

VirtualCZ comes with a library of over 200 presets specially developed for the plug-in.
Patches designed for the CZ hardware synths can be imported into the plug-in, providing
they are in a suitable SYSEX format.

The controls for managing presets are at the very top of the plug-in’s user interface. You
can get started just going through them with the Next Preset button (arrow pointing right)
(See Figure 2.1).

4 P 01: BRASS ENS.1 FILE S

Figure 2.1: The Preset Controls Section

2.1 Factory Presets
The five banks that come with VirtualCZ are as follows:

e Bank A - 64 presets by Oli Larkin

Bank B - 64 new presets by Don Solaris

Bank C - 64 presets originally designed for the CZ-1 by Don Solaris

Bank D - 64 presets by Scott AbstractCats

Bank E - A further 30 new presets by Don Solaris

sounce map
Carnival

Bank A (OL) CafioTone
Bank B (DS) SN
Bank C (DS) CII’CIL{'( Bent
Bank D (AC) Classic Dark
Bank E (DS) Dream Boat
DripBass
Ducky
Emox
Evolver
Flex Delay

Farmantich

Figure 2.2: Clicking the patch name to bring up the .vstpreset browser

By default VirtualCZ will use its own .vstpreset browser (see below), but if you want you can
turn this off and just use the preset browsing options in your DAW since the factory presets
are supplied in different file formats for each plug-in format (.fxp/.fxb for the VST2 plug-in,
.vstpreset for VST3 plug-in, .aupreset for Audio Unit plug-in and .tfx for the AAX plug-in).
This means that preset management can be handled via the host’s mechanisms if you so
wish. If you only use one plug-in format this might be the best option for you. For instance if
you are using the Audio Unit version of the plug-in in Logic you can save and load .aupreset
format files via Logic. DAWs will often provide an integrated preset browser that appears
when you insert the plug-in on a track, which can be a convenient way to manage your
presets in a consistent manner.



2.2 About Banks of Presets

Only the VST2 version of VirtualCZ has a notion of a "bank" of presets so extra options are
available for dealing with banks in that version. You can save and load .fxb (VST2 bank)
files that contain 64 presets and when you save a project in the DAW containing the VST2
version of VirtualCZ it saves the state of all the 64 presets. Certain bank-related preset
controls are disabled by default in the other versions. If you want to use banks of presets
with the VST2 version, it is recommended you turn the .vstpreset browser off.

Support for banks of presets also means that you can import a SYSEX file that contains
multiple presets directly into the VST2 version of the plug-in. In other formats, you will be
prompted to extract individual .syx files first if the SYSEX file you are trying to load contains
multiple patches.

2.3 VirtualCZ Preset Browser Mode

You can enable/disable the .vstpreset browser by clicking the "FILE" button and clicking the
"Use .vstpreset browser" entry so that it shows a tick. This is a global preference that means
that the preset controls in VirtualCZ will allow you to browse VST3 format presets on your
computer’s hard drive in the designated locations for system (factory) and user presets.

Initialize

Save Preset
Load Preset

v Use .vstpreset browser

; Reveal System .vstpreset folder... g
| Reveal User .vstpreset folder...

Figure 2.3: Enabling/Disabling .vstpreset browser

The VSTS3 .vstpreset locations are as follows:

Mac
System:

/Library/Audio/Audio/Presets/Plugin Boutique/VirtualCZ
User:
~/Library/Audio/Audio/Presets/Plugin Boutique/VirtualCZ

Windows
System:

hProgramData’%\VST3 Presets\Plugin Boutique\VirtualCZ
User:
%UserProfile’\Documents\VST3 Presets\Plugin Boutique\VirtualCZ

You can place your own presets in these locations, and they will show up in the preset
browser menu. There are entries in the "FILE" menu that will reveal these locations in the



OSX Finder/Windows explorer. You may require administrator privileges in order to place
presets in the system .vstpreset folder.

Initialize

Save Preset b -
Load Preset > =

v Use .vstpreset browser
Reveal System .vstpreset folder...

Reveal Use_____ .wvstpreset folder...

Figure 2.4: Opening the user/system .vstpreset folders in OSX Finder or Windows Explorer

2.4 Creating Presets

If you want to start from scratch, VirtualCZ has a feature to initialize the state of the plugin.
Click the "FILE" button and select "Initialize".

2.5 Naming Presets

VirtualCZ supports multiple preset formats and can cope with CZ-1 SYSEX, so the plug-in
has a place to store the name of the patch. You can edit this by SHIFT clicking the blue
part of the preset controls. This is what will be sent to a CZ-1 (the only CZ to support patch
names) if you send it the SYSEX. When dealing with .vstpresets in the .vstpreset browser,
it is the file name that is listed - so that would usually match the name you had given the
patch.

£ IR O iy New Patchl

Figure 2.5: Renaming a patch after SHIFT clicking

2.6 Saving Presets

There are a couple of different options for saving presets depending on what version of the
plug-in you are running.
With .vstpreset Browser on

Clicking the "S" button (see figure 2.6 ) is the quickest way to store a .vstpreset. You are
advised to store your .vstpresets in the user .vstpreset folder, but you can put it elsewhere.
It must be in the system or user .vstpreset folders if you wish to see it in the .vstpreset
browser.

With .vstpreset Browser off

In the VST2 version of VirtualCZ, when the .vstpreset browser is not enabled, pressing "S"
will save the current preset in the VST2 bank. This way you can go through all 64 presets,
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tweaking and pressing "S". Then using the "Save Bank..." options you can export all 64
presets in the bank to the other formats of preset. The preset controls will be disabled in
VST3, AU and AAX.

2.7 Sharing/Converting Presets

If you wish to export the current state of the plug-in to a file format compatible with another
plug-in format, you can use the options in the "Save preset..." submenu of the "FILE" menu.
Likewise you can load in various formats with the "Load preset..." sub-menu.

Save Preset Nl
Load Preset VST3 (.vstpreset) ...

audiounit (.aupreset) ...

Save Bank protools (.tfx) ...

Load Bank

SYSEX (.syx) ...
Use .vstpreset browser SYSEX (.mid)

Reveal System .vstpreset folder...
Reveal User .vstpreset folder...

Figure 2.6: Save the current state to a particular preset or SYSEX file

Importing Patches from SYSEX files

One of the features that differentiates the various CZ hardware synths is the number of
presets that they can store. The flagship model, the CZ-1 was capable of storing 64 user
presets, the CZ-5000/CZ-3000 could store 32 user presets and the CZ-1000/CZ-101 could
store 16 user presets (as well as 16 factory presets that could not be changed). This
means that SYSEX files that you want to load may contain a single preset, or they may
contain multiple presets.

Since the VST2 plug-in format supports banks of presets, the VST2 version of VirtualCZ
will allow you to import up to 64 presets from a single .syx or .mid file. The other formats
will first ask if you want to extract the individual sounds as .syx files. Choose a folder to
extract them to and then load the individual .syx files one at a time.
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3 Control/Parameter Reference

This section describes the various controls/parameters of VirtualCZ in detail. The controls
are described section by section. For most of the controls the automation parameters that
they link to are also grouped similarly and depending on your plug-in host you may have to
navigate to a particular group to automate that parameter.

1 | Sl Virtualcz [R] [MI[s] I

1VirtwalCZ |  Linel DCW Base

, o Main »

Detune Fine
Detune Oct
Detune Polarity
Detune Semi

PITCH EG 1
PITCH EG 2
DCW EG L
DCW EG 2
AMPEG 1
AMP EG 2
VIBRATO
RESERVED

Linel Shape B
Line2 DCW Base
Line2 Shape A
Line2 Shape B
Mix Mode
Modulation Mode
Phase Reset

[
»>
»>
»>
[
»>
»>
»>

Figure 3.1: Audio Unit parameters are organized into sections

3.1 Notes about the controls

Before we look at the various groups of controls it is worth discussing some common fea-
tures.

Tool Tips
Hover your mouse over a control to bring up a tooltip with some helpful information about
what the control does.

Mouse Behaviours

All the controls on the VirtualCZ user interface use similar mouse and keyboard behaviours
to operate them.

e ALT-CLICK or DOUBLE-CLICK a control to reset it to its default value
e SHIFT-CLICK a control to enter a precise numerical value via the keyboard

e Hold down SHIFT while dragging a control to reduce the speed of value changes and
to set it more precisely

e OPTION-CLICK or RIGHT-CLICK a control to bring up MIDI Learn options.

e In a VST3 host such as Steinberg Cubase or Presonus Studio One, OPTION-CLICK
or RIGHT-CLICK will also allow you to creat a host context menu for that parameter.

¢ In the AAX version of VirtualCZ, you can use standard Pro Tools commands such as
CTRL-ALT-CMD/CTRL-ALT-START-CLICK in order to bring up the Pro Tools automa-
tion dialog.

12



LCD Readouts and Conversions

When you move a parameter the parameter name and value will be displayed in the LCD.
Since VirtualCZ is an editor for CASIO CZ hardware, as well as an emulation, certain con-
trols must retain their original units, in order that they transfer to the hardware and that
editing is intuitive. This means that some controls have ranges or units that are uncommon
in modern virtual instruments (for instance, the MSEG envelope rates are set in units of
0-99, rather than in time in milliseconds). Where it makes sense, VirtualCZ will display a
conversion on the LCD to more logical units.

[

Figure 3.2: VirtualCZ’s LCD displaying the CZ style rate in 0-99 units and a conversion to milliseconds

Parameter Locks

When browsing presets, often we’d like certain aspects of the patch to stay the same.
For instance, if we have customised the scaling of MIDI velocity or aftertouch messages
to match a particular MIDI keyboard, we may not want that to change when the preset
changes. VirtualCZ features several lock toggles that will protect certain parameters in the
event of a new preset being loaded. The states of the locks are not saved when you store
a DAW project or save a preset.

)

Figure 3.3: Locking parameters

Copying Values, Randomising and Resetting

The various grouped "sections" of controls in VirtualCZ can be reset, randomised and mod-
ified via some special options. If you mouse-over the title of a section it should flash to
indicate that you can click it. If you click the title, a menu will give you various options that
will apply only to the controls that belong to that section. Areas, such as the EG headings
allow you to copy and paste the values of one EG to another.

13
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Figure 3.4: The areas where you can click to copy/reset/randomise a section’s controls

Randomise
Reset

Figure 3.5: Click on the Env Line heading to copy/randomise/reset that Line’s EG controls

Randomise
Reset

Figure 3.6: Click on the individual EG headings to bring up a menu to randomise/reset/copy/paste the values
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3.2 MASTER Section

The master section contains controls that affect the overall behaviour of a patch and controls
for "special" effects such as chorus, unison and panning.

POLY
LEGATO

MONO

Figure 3.7: The MASTER Section

Polyphony Mode

The Poly Mode parameter can be switched between poly, legato and mono modes. Legato
mode is a monophonic mode - when a key is held and another key is pressed, the synth’s
envelopes are not re-triggered. Both mono mode and legato mode are lowest note priority.
Polyphonic mode supports a maximum of 32 notes of polyphony.

Unison Voices

When Poly Mode is set to mono or legato, the Unison Voices parameter is enabled and
allows a choice of between one and eight voices of unison. If you send a MIDI note-on
message to VirtualCZ it will cause multiple voices to play at the same pitch, which can be a
useful way of fattening a lead or bass sound.

Unison Detune

When Poly mode is set to mono or legato and the Unison Voices parameter is set higher
than 1, the Unison Detune parameter will detune the stacked unison voices.

Portamento Time

When set to zero, no portamento is applied and when a new key is pressed the oscillators
will receive the new pitch immediately. When this parameter is greater than zero the oscil-
lators will take time to reach the new pitch. Portamento in VirtualCZ is of the constant time
variety, so it always takes the same amount of time for the pitch to get to the desired pitch,
regardless of the distance between the start and end pitch.

Bend Range

This parameter controls the range (in semitones) of pitch deviation caused by MIDI pitch
bend messages.

15



Master Tune

By default VirtualCZ is tuned to concert A = 440Hz. If you wish to adjust the master tuning
this parameter will let you raise or lower it by up to 100 cents. This tuning shift will work
even if you have customised the tuning table to something other than the default 12 TET.

CHORUS PAN

Figure 3.8: The Chorus and Pan Width controls

Pan Width

The Pan Width parameter introduces stereo panning in order to create a wider stereo image.
The parameter has a different effect depending on the setting of the Poly Mode parameter.
When Poly Mode is set to Polyphonic, if Pan Width is greater than zero, a random pan
position is applied to each voice. The higher the Pan Width, the wider the spatialization. If
the Pan Width parameter is at 100% it is possible that a voice could be panned completely
left or completely right. When Poly Mode is in either of the monophonic settings and the
Unison Voices parameter is greater than 1, the Pan Width controls the spread of the voices
playing in unison across the stereo image.

Chorus Depth
Several of the CZ hardware synths featured an analogue stereo chorus section. VirtualCZ
features an emulation of this and this control sets the strength of the chorus effect.

Chorus Mode

Click the word "CHORUS" to switch chorus mode. There are two stereo chorus algorithms
in VirtualCZ. The first (Chorus Mode A) is the default and is a quite clear sounding chorus
modelled on the Roland Dimension D. The second algorithm (Chorus Mode B) is a more
lo-fi modelled on the Chorus/Ensemble effect that was in the CZ synths.

Master Volume

Controls the overall volume of the synth. If you ever find the output of VirtualCZ is pushing
your DAW’s meters into the red, you can decrease the volume here.

16



3.3 OSC Section

This section allows adjustment of the oscillator settings for the two CZ "Lines" including the
way they are mixed, detuned and modulated.

OCTAVE LINE 1
S 3
H
A SEMI

LINE 2
Y el g
POL +

/

Figure 3.9: The OSC Section

Line Shape

For each Line there are two enumerated list parameters that affect the wave shape; one for
each alternating cycle produced by the Line’s oscillator. The shape’s name describes the
resulting waveform when the DCW (the amount of phase distortion) is at it's maximum. On
the user interface there is a third control that is not represented by a parameter that allows
you to quickly set both of the Line’s shape parameters to the same value. This control
is accessed by clicking directly between the Line’s Shape A and Shape B controls (see
Figure 3.11).

Figure 3.10: The 8 Waveshapes

Each of these three controls provides the following 8 options:

No. | Waveform | Description

1 Saw Sine wave moving to sawtooth at max DCW

2 Square Sine wave moving to square at max DCW

3 Pulse Sine wave moving to impulse at max DCW

4 DblISine Sine wave moving to double sine

5 SawPulse | Sine wave moving to saw/pulse hybrid

6 Reso1 Hard-synced sine wave with sawtooth envelope
7 Reso2 Hard-synced sine wave with triangle envelope
8 Reso3 Hard-synced sine wave with trapezoid envelope

17



4 - DblSine
5 - SawPulse
6 - Resol

7 - Reso2

8 - Reso3

Figure 3.11: Clicking in-between the shape buttons to set both shapes at once

Line DCW Base

This parameter, which doesn’t exist on the CZ hardware, allows the setting of a base-value
for the DCW amount, and is the closest equivalent to a filter-cutoff control on a subtractive
synth. If you wish to invert the DCW Envelope for a Line you can set the to the maximum
(100%) and set the DCW Envelope depth to a negative value.

Mix Mode
The Mix Mode parameter chooses whether you have one or both of the CZ lines engaged.

Mix Mode Setting | Description

Line1 Line 1 on its own

Line2 Line 2 on its own

Line1 + Line?’ Line 1 and a detuned version of itself
Line1 + Line2 Line 1 and Line 2 at the same time

[ MIx ]
BPM
LINE 1

LINE 1 -
—_

Linel |

Line2
Linel + Line2
v Linel + Linel'

Figure 3.12: Line Mix Mode menu

Detune Polarity

This is a simple switch parameter that determines if the detune settings for the second line
(in Mix Modes Line1 + Line1’/ Line1 + Line2) should be positive or negative.

Detune Oct

The number of octaves to detune the second line by between 0 and 3.

Detune Semi
The number of semitones to detune the second line by between 0 and 11.

18



Detune Fine

This is a fine detune for the second line and can be used to create interesting beating and
chorusing effects. Like the CASIO hardware, the increments for fine tune are a 60th of a
semitone, rather than the more conventional cents (100th of a semitone) often used when
detuning. If you look in the VirtualCZ LCD it shows a conversion to cents as you change
the parameter.

OCTAVE
3

SEMI
0

Figure 3.13: Line detune settings

Modulation Mode

The Modulation Mode, which is enabled when two lines are engaged (i.e. Mix Modes Line1
+ Line1’ or Linel + Line2), can be set to either Ring (the output of Line 2 or Line1’ is
Ring Modulated with the output of Line 1), or Noise (the pitch of Line 2 is modulated by
a noise/random function). Ring Modulation is good for creating inharmonic tones, such as
bells and metallic percussion, whereas noise is good for special FX sounds.

Figure 3.14: Line Modulation Mode menu

Phase Reset

The oscillator Phase Reset parameter, which is not found on the CZ hardware, is only really
relavent for the monophonic unison modes. When phase reset is on, the oscillators will
start at the same position in the waveform when a note is played. When multiple voices
are in unison and detuned this means that the same pattern of phasing and beating effects
is repeated each time a note is triggered. This can be desirable for tight bass and lead
sounds, but sometimes a more mellow unison is preferable, in which case the oscillator

phase reset can be disabled.

Figure 3.15: Phase Reset toggle switch
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3.4 ENV (Envelope Generators) Section

One of the most powerful features of the CZ synths is the six 8 stage envelope generators
(EGs), which allow complex modulations with stages that can either be extremely quick
or extremely slow, or somewhere in between. Setting the parameters for 8-stage multi-
segment ( MSEG) envelopes can be confusing and time consuming even for the most adept
sound designers, so VirtualCZ provides an option to switch all the envelopes to the more
familiar ADSR type, as found on most analogue synthesisers. Since there are six EGs per
voice, each with very similar settings, the following descriptions are generic.

Figure 3.16: ENV Section: Line 2 Amp Envelope controls in MSEG Mode and ADSR Mode

EG Mode

This switch, which is located in the bottom right hand corner of the plug-in’s user interface,
will allow you to choose between MSEG and ADSR modes, and will show/hide the controls
that correspond to the currently selected mode. It's important to understand that the plugin
makes no attempt to "convert" between one envelope type and the other - the parameters
are independent and if you tweak ADSR settings and switch to MSEG your sound will be
different - naturally.

Depth (PITCH and DCW EGs)

On the PITCH and DCW envelopes, the EG Depth parameter is bi-polar and it can range
from +/- 84 semitones and +/- 100%, so that the effect of the envelope can be inverted and
scaled. This parameter did not exist on the original CZ hardware, so when sending SYSEX
messages you should probably set it to the maximum value if you want the sound to be
similar.

Level (AMP EG)

On the AMP EGs, there is a Level parameter to control the overall volume of each line,
which corresponds to the Line Level on the CZ-1 hardware. Like the hardware, there are
16 values that range between 0 and 15.

Velocity

This parameter controls the amount that MIDI note-on velocity influences the envelope. If
the parameter is set to zero, then the velocity will have no effect on the envelope depth.
Like the hardware, there are 16 values that range between 0 and 15.
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Key Follow (DCW and AMP EGs only)

On the DCW and AMP EGs a Key Follow parameter sets the amount of influence the pitch
played has on the envelope. For the DCW EG the depth of the envelope is modified. This
can be important, for instance, when emulating the sound of acoustic instruments, where
you might want to roll off the DCW amount the higher the pitch in order to emulate a varying
spectrum across the keyboard range. For the AMP EG, the Key Follow parameter modifies
the rate of the envelope, where higher values mean that higher pitches have faster rates
i.e. they notes are shortened. Like the hardware, there are 10 possible values that range
between 0 and 9.

Rate Controls (MSEG Env Mode only)

The rate controls set the speed of each envelope segment, using the same 0-99 range as
the CZ hardware. The higher the rate, the faster the envelope segment. Rate increases
clockwise, so the fastest envelope setting is all the way to the right.

Level Controls (MSEG Env Mode only)

The level controls set the level of each envelope segment, using the same 0-99 range as
the CZ hardware.

Sustain Step (MSEG Env Mode only)

You can choose between "off" or steps 1-7 to say where in the MSEG envelope the pro-
gression should stop whilst a key is held down. If the End Step is lower than the Sustain
Step, then the Sustain Step has no effect.

End Step (MSEG Env Mode only)

This is the point at which the envelope ends and can be set between 2 and 8. Redundant
Rate/Level controls will be greyed out if this parameter is changed.

Loop Enable (MSEG Env Mode only)

A loop option, not found on the CZ hardware. If the Sustain Step is not set to "off" the
envelope will loop all the stages up to the Sustain Step, then return to the beginning. On
release it will continue with the rest of the envelope.

Attack (ADSR Env Mode only)

This sets the attack time in Milliseconds/Seconds.

Decay (ADSR Env Mode only)

This sets the decay time in Milliseconds/Seconds.

Sustain (ADSR Env Mode only)

This sets the sustain level (a percentage of the maximum envelope level).

Release (ADSR Env Mode only)

This sets the release time in Milliseconds/Seconds.
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3.5 VIBRATO Section (LFO)

Like the CZ hardware synths VirtualCZ has one Low Frequency Oscillator (LFO), which is
assigned to vibrato. The LFO in VirtualCZ is more flexible than the hardware - it has more
waveforms and can be synchronised to the DAW’s tempo.

Figure 3.17: The VIBRATO Section

Vibrato Rate Mode / Vibrato Rate

The Vibrato Rate Mode parameter determines whether the Vibrato Rate is set with a (BPM)
beat based division or a (Free) rate in the range 0-99 like on the CASIO hardware. SHIFT-
CLICK the rate knob when Vibrato Rate Mode is set to BPM to bring up a menu of all the
options (see figure 3.18).

1/2
1/4D
1/4
1/8T
1/8D
1/8
1/16T
v 1/16D
1/16
1/32
1/64

Figure 3.18: SHIFT-CLICK the Vibrato Rate menu

Vibrato Depth

This sets the depth of the Vibrato modulation in CZ units of 0-99. The LCD readout shows
the equivalent in semitones (maximum 12 semitones/1 octave).
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Vibrato Trig Mode

The Vibrato Trig Mode parameter determines whether the LFO’s phase is aligned with the
DAW’s timeline. If you want to produce precisely repeatable results you can set this to "Host
Sync" rather than "Free".

Vibrato Shape

VirtualCZ has 7 different vibrato LFO waveforms, versus 4 on the CZ hardware. They are
as follows:

No. | Waveform Available on real CZ?
1 Sine NO

2 Square YES

3 Triangle YES

4 RampUp YES

5 RampDown YES

6 SAH (Sample & Hold) NO

7 Noise (Interpolated Sample & Hold) | NO

When transferring a patch via SYSEX that uses a waveform not on the hardware it will be
set to Triangle.

Vibrato Delay

This is a fade-in time on the Vibrato when a note is trigger. Unlike the CZ hardware it is a
gradual fade in, rather than purely a delay, however, the units are 0-99 like on the hardware.
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3.6 SCALING Section

Because MIDI keyboards often have very different responses and players play keyboard in
different ways, VirtualCZ contains a scaling section where incoming velocity and aftertouch
values can be remapped to new ones.

Figure 3.19: The SCALING Section

For both velocity and aftertouch there is a two dimensional table where you can draw a map-
ping curve by clicking and dragging with the mouse. Input level is on the X axis and output
is on the Y axis. In order to draw straight line segments you can hold down SHIFT and click
the start and end points of your line. You can also use the MAX button to remove all velocity
influence and set all values to maximum and the LIN button to revert to the default linear
mapping. A CURVE button can be used to make a variable curvature in the mapping; to
use it click and drag up or down. You can also click and hold the LEFT/RIGHT/UP/DOWN
arrows in order to shift the entire mapping.

It's worth noting that these scaling settings will have no effect if none of the envelope gen-
erators have been set to respond to velocity.

Figure 3.20: Aftertouch Mode and Routing controls

Aftertouch Mode

VirtualCZ supports both channel pressure and polyphonic aftertouch, but not both at the
same time. You can choose which is enabled here.

Aftertouch Routings

The modulation from the aftertouch can be routed to LFO (Vibrato) Depth, Volume (AMP)
or DCW.
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3.7 Miscellaneous Controls

LCD Backlight Colour

By clicking the VirtualCZ LCD, you can bring up a menu to choose one of three backlight
colours. The LCD backlight colour is a global preference.

Figure 3.21: Setting the LCD Backlight Colour

Panic Button and MIDI Activity LED

VirtualCZ has a MIDI activity LED that will flash whenever a MIDI note is received. You can
also click it to reset all the voices in case of one getting stuck.

Figure 3.22: The LED to show MIDI activity doubles up as a PANIC! button
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4 Using VirtualCZ as a SYSEX Editor

VirtualCZ can send patches to the CASIO CZ synths (CZ-1, CZ-101, CZ-1000, CZ-3000,
CZ-5000). At this stage the CZ-230s is not supported.

The CZ synths use SYSEX dumps, which means the entire state of the synth is sent in one
go. This means it is not possible to send SYSEX messages to automate a single parameter.
Sending SYSEX from a computer to an old synthesizer can often be unreliable due to
various factors. Many USB MIDI interface drivers are poor quality and will have problems
with the significant amounts of data required by SYSEX. We recommend you use a high
quality MIDI interface and avoid sending SYSEX at the same time as other MIDI data.

The "TOOLS" button at the top of the plug-in’s interface is where you can perform SYSEX
sending commands (see Figure 4.1). You can SHIFT-CLICK the "TOOLS" button to send
SYSEX, as well as using the "Send SYSEX" item on the popup menu.

TOOLS

Figure 4.1: The TOOLS button/menu. SHIFT-CLICK to send SYSEX

There is also an option to automatically send SYSEX when a parameter is changed in the
plug-in (see Figure 4.2). This will send a SYSEX message every second if a parameter
has changed. This means that when you choose a preset in VirtualCZ or alter any control
the patch will get transferred to the hardware. Since the message is a SYSEX dump sent
every second, this is not suitable for automating parameters in real-time, and you are rec-
ommended to turn it off during playback in your DAW and only use it during the process of
editing your CZ patch.

Send SYSEX

v Auto Send SYSEX

Set Model
Set Patch Slot
Set MIDI Qut

Open Manual

Figure 4.2: Send SYSEX and Auto Send SYSEX

Host MIDI or Direct MIDI out?

Many audio plug-in hosts (e.g. DAWSs) do not handle SYSEX messages well (if at all),
so VirtualCZ features its own direct MIDI output that can bypass the host’s MIDI settings,
although by default the MIDI output will be routed to "Host MIDI" (see Figure 4.3). This
is a global setting, with the assumption that if you have a CASIO CZ hardware synth you
leave it connected to a particular MIDI port, and whatever DAW you use it will send to the
synth, without having to configure the DAW’s MIDI settings each time. On Windows, you
will probably need to make sure that the DAW is not also trying to use the same MIDI device
and disable it in the DAW preferences if so. VirtualCZ will give you an error message if it
can’t open the MIDI device. The MIDI output in VirtualCZ is a global setting, so it is only
designed to work with a single CZ synth at a time. If it is not possible to assign VirtualCZ it's
own MIDI device, or if you have multiple CZ synths you want to work with, then you should
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use the "Host MIDI" setting and a DAW that supports SYSEX coming from plug-ins. In this
situation, you will need to consult your DAW’s documentation to route an the MIDI output
from the VirtualCZ to a hardware MIDI output.

Send Sysex

Set Model
Set Patch Slot y
Set MIDI Qut L v Host MIDI

Open Manual Network Session 1
828mk2 MIDI Port

ipMIDI Port 1

s ipMIDI Port 2

Figure 4.3: Choosing the MIDI output

Steps to send SYSEX

The first thing to do when sending SYSEX is to make sure you have a MIDI cable going
from the MIDI output of your MIDI Interface to the MIDI input of the CZ hardware. You can
test the connection by sending a MIDI note message from your DAW to the hardware. You
will need to choose your CZ model (see Figure 4.4) and choose the patch slot destination
(see Figure 4.6). The CZ model is a global setting.

Send Sysex

OlaEaEaEaks

Set Model
Set Patch Slot »
Set MIDI Qut

Set Model 91, CZ-1000

Set Patch Slot CZ-3000, CZ-5000
Set MIDI Out v CZ-1

Open Manual

Open Manual

[=RwRwlviwiele]

Figure 4.4: Choosing the CZ Model
Figure 4.5: Choosing the Patch Slot

Below are the steps to follow for the various CZ hardware models. Red text indicates
something that you do in VirtualCZ and blue text indicates something that you do on the CZ
hardware.

CZ-101/CZ-1000
e Set Model To "CZ-101, CZ-1000" in Tools->Set Model
e Choose one of the 16 patch slots in Tools->Set Patch Slot -> 1 to 16
e Make sure "PROTECT" is switched t0"OFF" on the back of the synth
e Make sure COMPARE/RECALL is not illuminated

e Select the "Internal" memory on the CZ-101, CZ-1000 that you wish to send to (e.g.
Internal No.1)
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e Select Tools-> Send SYSEX

CZ-3000 / CZ-5000
e Set Model To "CZ-3000, CZ-5000" in Tools->Set Model
e Choose one of the 32 patch slots in Tools->Set Patch Slot -> A1 to D8
e Make sure "PROTECT" is switched to"OFF" on the back of the CZ-3000 / CZ-5000
e Make sure COMPARE/RECALL is not illuminated

e Select the MEMORY on the CZ-3000 / CZ-5000 that you wish to send to (e.g. MEM-
ORY A-1to D8)

e Select Tools-> Send SYSEX

Cz-1
e Set Model To "CZ-1" in Tools->Set Model
e Choose one of the 64 patch slots in Tools->Set Patch Slot -> A1 to H8
e Make sure "PROTECT" is switched to"OFF" on the back of the CZ-1
e Make sure SYSEX is enabled on the CZ-1

— Press the button labelled "MIDI" to the immediate left of the LCD, to view MIDI
options

— Press the page down button (labelled "DOWN") to change to the second page of
MIDI options

— Press the value up button (with an upwards arrow on it) so that the LCD shows
"SYSTEM EXCLUSIVE TONE DATA=ENA"

e Select the MEMORY BANK on the CZ-1 that you wish to send to (e.g. MEMORY A-1
to H8)

e Select Tools-> Send SYSEX
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Requesting patches From CZ Synths

VirtualCZ 1.1 adds functionality to allow the software to request SYSEX patches from the
CZ hardware, one at a time. In order to do this, make sure the MIDI input/output in the
TOOLS menu are routed to the CZ hardware - choose "Set MIDI Output.." in VirutalCZ and
select the port on your MIDI interface that is connected to your CZ’s MIDI input socket, then
choose "Set MIDI Input..." and choose the port on your MIDI interface that is connected to
your CZ MIDI output socket. Once you have your MIDI connections routed, you can follow
these steps to pull a sysex patch from the hardware, into the software. Please note, that if
you want to save this patch, you will then have to export it into a particular format.

e Set Model in Tools->Set Model, to choose your CZ model
e Make sure "PROTECT" is switched to"OFF" on the back of the CZ hardware
Make sure COMPARE/RECALL is not illuminated, if your device has that button

Make sure SOLO is not enabled, if your device has that button

If conntected to a CZ-1, make sure SYSEX is enabled, see above

Request one of the patches on the hardware device in Tools-> Request SYSEX ->
(different CZ models will show different options)

Send SYSEX
Auto Send SYSEX

Request SYSEX

TRIDGE >
et Model

Set Destination Memory
Set MIDI Output
Set MIDI Input

Open Manual

Figure 4.6: Requesting patch B-6 from a CZ-1

29



Hardware vs Plug-in

Below is a list of differences between the VirtualCZ emulation and the CASIO CZ hard-
ware. The plug-in has been modelled without any insider knowledge of the CZ synthesiser
firmware, so it has not been possible to make a 100% accurate mapping of parameters
to the synthesis engine, which can sometimes show when directly comparing a patch on
VirtualCZ with the same patch on a real CZ. More often than not, a slight tweaking of the
envelope controls or velocity influence settings in VirtualCZ can help match sound from the
hardware more precisely.

VirtualCZ new features ...

Front panel controls for the majority of synth parameters

UNISON (up to 8 voices) mode with detune amount

Random panning of each note in polyphonic mode

Stereo spread of voices in in unison mode

MSEG (8-stage) Envelope generator can be looped

Base DCW amount for each oscillator, which can be used like a "filter cutoff" parameter

Envelope depth controls that can be positive or negative for PITCH and DCW en-
velopes

Envelopes can be switched to ADSR style instead of MSEG (8-stage)
Micro-tonal tuning support

LFO can be synchronised to DAW tempo

7 Vibrato LFO shapes (vs 4 on the hardware)

No restriction on combinations of Oscillator wave shapes

32 voice polyphony with both lines on (CZ-1 had 8 voices, CZ-101 had 4 voices)

Modulation wheel controls the depth of Vibrato and is independent of the Vibrato Depth
control

Hardware CZ features that are not in VirtualCZ ...

no "Operation Memory" (OP-MEM) modes as found on the CZ-1

VirtualCZ does not feature "Tone Mix" or "Key Split" modes. These can be imple-
mented more flexibly by making multiple copies of the plug-in within the DAW

VirtualCZ is mono-timbral (use multiple instances for multiple sounds)

No "Glide" as found on the CZ-3000, CZ-5000 and CZ-1
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5 Using Tuning Tables

For users interested in micro-tonal music, VirtualCZ allows you to detune each MIDI note.
It would be very laborious to do this manually, so it supports importing custom tunings via
the popular .tun tuning table format. The tuning table is stored per patch and the lock can
be enabled to stop new presets overwriting it.

Using .tun Files

The .tun format specifies a base frequency and a list of tuning offsets from the base fre-
quency in cents for each pitch on the keyboard (there are 1200 cents in one octave). Click
the LOAD button to select a .tun file. Click the RESET button to get back to 12 tone equal
temperament.

You can find .tun files and resources on the internet:

e About the .tun tuning table format
e Scala to .tun converter

e .tun generator

Manually Adjusting Tuning

You can type in a base frequency and the tuning offsets in cents for each MIDI key manually.
Clicking in the squares to the left of the tuning table box chooses the octave that is displayed
on the keys/notes in the middle. The exact tuning can be specified in the text entry boxes
adjacent to the keys. Sending a MIDI Note-On message to VirtualCZ (e.g. by playing a key
on your MIDI keyboard) the display should highlight the corresponding octave/key in the
tuning interface to help you find the correct place (see Figure 5.1). You can also click one of
the 12 keys in the middle of the tuning table to trigger a MIDI note for that key and audition
any tuning changes.

Figure 5.1: Tuning Table
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6 Stand-alone Application

When using the Stand-alone version of VirtualCZ, you need to specify what audio and MIDI
devices to use. You can change these settings in the applications preferences, which is
accessible from the application menu on OSX or the File menu on Windows. The choices
are remembered when you close VirtualCZ, but if your devices change (for instance if you
disconnect your audio interface), you may need to adjust the settings, because VirtualCZ
will revert to the default audio interface, as specified by the operating system.

When using the Stand-alone Application to send SYSEX, your MIDI output must be chosen
inside the application preferences window.

Preferences
Audio Device Settings
8600 Preferences Diriver Type 10 Vector Size

Audio Device Settings |A3|U ﬂ l512 LI
Audio Device 10 Vector Size Input Device

Built-in Output 2 512 : [asingarve <]
Out1(L) Out2(R) Sampling Rate Output Device Sampling Rate

T B R 44100 v [asi04aLL v2 > [as100 -l

Output 1 (L] Output 2 [R]
Audio Midi Setup... m m A510 Config...

MIDI Device Settings

MIDI Device Settings .
Input Device Input Channel

Input Device Input Channel

[ off = a =l

virtual input b= all =
Output Devi onanen i Output Device Output Channel

utpu evice utpu anne|
ft 2 ] @
off = all H |0 _l [a _]
Apply oK Cancel Apply | oK | Cancel |
Figure 6.1: App Preferences Dialog on OSX Figure 6.2: App Preferences Dialog on Windows

Driver Type (Windows Only)

Select the kind of audio driver to use (DirectSound or ASIO). ASIO will allow lower latencies.
If you don’t have an ASIO driver, you may be able to use ASIO4ALL.

Input/Output Device

The physical device used for 10.

Out 1 (L) / Out2 (R)

The physical channels used for audio output (they must be consecutive).

10 Vector Size

The audio hardware buffer size. Increase this setting if you experience audio glitches
(higher settings results in higher latency but less CPU usage).
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Sampling Rate

VirtualCZ supports sample rates up to 192kHz if your audio interface supports it. Higher
sampling rates mean better sound quality and lower latency, but result in more CPU usage.

AudioMidi Setup / ASIO Control Panel

This button will launch the OSX AudioMidi Setup app or your audio interface driver's ASIO
control panel on Windows.

MIDI Input Device

Choose the MIDI input device. On OSX you can choose "virtual input" to create an IAC (inter
application communication) driver that will appear as a midi output in other OSX software.

MIDI Input Channel

Filter the incoming MIDI messages to only use the specified channel.

MIDI Output Device

Choose the MIDI output device.

MIDI Output Channel

Filter the incoming MIDI messages to only use the specified channel.
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7 Host Notes

This section contains information regarding using VirtualCZ in specific plug-in host applica-
tions. As a general note for hosts that support multiple plug-in formats - it's best just to stick
to one format and not switch between them or use two formats in one DAW project. Since
VirtualCZ works as both a 32 bit (x86) and 64bit (x64) plug-in, you should never need to
"bridge" it with a bit-bridge plug-in. Use the 32 bit version in a 32 bit DAW and use the 64
bit version in a 64bit DAW.

ImageLine FLStudio

Although FLStudio supports both VST3 and VST2, we recommend you use the VST2 ver-
sion of VirtualCZ in FLStudio, because the FLStudio VST3 wrapper has some GUI focus
issues with VirtualCZ.

Avid Pro Tools

In Pro Tools, VirtualCZ should respect the conventions for mouse behaviours, and when
you automate a parameter it should be highlighted in the plug-in GUI.

Ableton Live

On Mac OSX, Ableton Live supports both VST2 and Audio Unit plug-in formats. You can
use either. One advantage of using the VST2 version is that your project will transfer to
a Windows machine running Live (Windows does not support Audio Unit plug-ins). One
advantage of using the Audio Unit version is that VirtualCZ's .aupreset preset files are
indexed and browsable in Abelton Live’s browser.

Ableton Live does not support SYSEX internally, so you must use the direct MIDI output if
you wish to send SYSEX to CZ Hardware.

Steinberg Cubase/Nuendo

Steinberg hosts will only show the VST3 version of VirtualCZ if you have both the VST2
and VST3 versions installed. VST3 is the preferred format for VirtualCZ in Steinberg hosts,
since you can use the DAW'’s .vstpreset browser and some nice features such as right-
clicking parameters to bring up a contextual menu where you can add the parameter to the
automated parameter list.
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8 Further Reading

There is a vast amount of information on the internet about the CASIO CZ series and about
phase distortion synthesis in general. Here are a few links to some of the best sites:

e Electric Druid - "Phase Distortion Synthesis - How it Works"

e PAUL WIFFEN: Synth School, Part 3: Digital Synthesis (FM, PD VPM)
e Michael Rickard’s CASIO CZ site

e Tomas Mulcahy’s CASIO CZ site

e CASIO CZ youtube channel

e GForce Software Synth Archive: CASIO CZ-101

e archive.org CASIO Synth Manual Collection

e CZsynth Yahoo group

e cosmosynthesizer.de [GERMAN]
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9 Support Info

You will be sent an email when VirtualCZ is updated, and it is recommended that you update
to the most recent version as and when a new version is released.

Contacting Support

If you experience a problem with VirtualCZ, the first thing to do is to login to your pluginbou-
tique.com account to check for a new version, which may fix the issue. If there is no new
version, you can contact support via email support@pluginboutique.com

When you email support it will help if you can provide the following information to help us
solve your issue as quickly as possible:

You can check the plug-in format, version number and whether you are using a 32 bit or 64
bit version on the about page by clicking the VirtualCZ or PIB logo in the top corners of the
interface.

e What is the VirtualCZ version number?
e.g. v1.0.0

e What plug-in format were you using?
e.g. VST2, VST3, Audio Unit, AAX or Stand-alone app

e What platform did you notice the bug on?
e.g. Windows XP, Windows 7 x64, OSX 10.8

e Please describe the spec of the machine you are using
e.g. i5 3Ghz, 4GB RAM / MacBookPro i5 2010 8GB RAM

e What is the name and version of your plug-in host?
e.g. Logic 9, Cubase 6.5, FLStudio 11

e Were you using the 32 bit or 64 bit version of the plug-in?
e.g. 32 bit

e If your issue relates to using VirtualCZ with CASIO hardware, which CZ model were
you using?
e.g. CZ-101, CZ-1

e ... and what MIDI interface were you using?
e.g. MOTU 828 Mkll

e Is the issue repeatable?
Can you make it happen again by following the same steps?

Feature Requests and Feedback

If you like VirtualCZ we'd really appreciate your feedback. You can rate the plug-in at
www.pluginboutique.com and review it on sites such as www.kvraudio.com.

If you have a feature request or a suggestion for future versions of the plug-in please contact
the developer.
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11  Glossary

ADSR Attack-Decay-Sustain-Release envelope generator.
DAW Digital Audio Workstation.
GUI Graphical User Interface.

MSEG Multi Segment Envelope Generator - an 8-Stage envelope generator. More powerful
than an ADSR but more confusing too.

Phase Distortion A type of sound synthesis first used in the CASIO CZ series synthe-
sisers, involving waveshaping of a phasor to distort a sine wave into various other
waveforms.

phasor A name given to a basic oscillator that is used to generate a periodic ramp to drive
a wavetable oscillator.

SYSEX MIDI System Exclusive message - a special type of MIDI message often used to
transfer sound patches between devices.

waveshaping Waveshaping is the name for a process whereby an input signal is pro-
cessed by a stateless function, in order to change the value at the output, for a given
input. This is typically used in audio effects to emulate non-linearities that cause dis-
tortion, but in the case of the CZ waveshaping is applied to the phasor part of the
oscillator in order to change the way that the stored wavetable is read.

wavetable A stored waveform (e.g sine wave), in the synthesiser/computer memory. Often
used as an efficient way to calculate things like sine waves that are slow using other
methods.
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12 License

VirtualCZ End User License Agreement

VirtualCZ (the Software) is developed by Oli Larkin (the Developer), under license for ex-
clusive distribution to Plugin Boutique Ltd, (the Distributor).

Caveat

By installing the Software you agree to use it at your own risk. Neither the Developer or the
Distributor can be held responsible for any damages caused as a result of its use.
Distribution:

Plugin Boutique Ltd are the sole distributor of the Software. Redistribution of the Software
without the express permission of Plugin Boutique Ltd is forbidden.

Multiple Installations:

If you purchased the Software as an individual, you are licensed to install and use it on any
computer you personally need to use it on, providing you remove all traces of it afterwards
if it is a shared machine, including any license files. If you purchased it as an institution
or company, you are licensed to use it on one machine only, and must purchase additional
copies for each machine you wish to install it on.

Updates:

If you purchased the Software you are entitled to free updates until the next major version
number. Neither Developer nor Distributor guarantee that this product will be maintained
indefinitely.

License transfers:

License transfers of the Software are not permitted.

Copyrights and trademarks:

VirtualCZ ©Copyright Oliver Larkin 2014-2019
www.olilarkin.co.uk

VST is a trademark of Steinberg Media Technologies GmbH

Audio Unit is a trademark of Apple, Inc.

Pro Tools(®R)is a trademark of of Avid Technology, Inc.

CASIO is a registered trademark of CASIO Computer Co., Ltd., Japan
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